LifterLMS Authorize.Net

LifterLMS Authorize.Net Version 1.1.0

  • The minimum required LifterLMS core version has been raised to version 4.9.0. Please ensure the LifterLMS core is upgraded in order to continue using this payment gateway.
Updates
  • Use llms() in favor of deprecated LLMS().
  • Added the ability to store API credentials as constants (in your wp-config.php file) or as environment variables. See our updated Getting Started Guide for more information.
  • Creation requests for a customer profile which already will now silently use the existing profile in favor of returning an error.
Bug Fixes
  • Retrieve $_POST data via llms_filter_input().
  • Ensure the profile is saved even when a duplicate is encountered.
Changes to private class members

The following changes have been made to private members of various classes. These changes do not constitute a breaking change but are noted for the sake of posterity:

  • Removed private class method LifterLMS_Authorize_Dot_Net::define_constants().
  • Private class property LifterLMS_Authorize_Dot_Net::$_instance changed to LifterLMS_Authorize_Dot_Net::$instance.
  • Private method LLMS_Authorize_Net_Charge::_get_transaction_request_data() renamed to remove the leading underscore prefix.
  • Private methods LLMS_Authorize_Net_Customer::_get_payment_profile_request_data() and LLMS_Authorize_Net_Customer::_get_profile_request_data() were renamed to remove the leading underscores prefix.
Deprecations
  • Function LLMS_Auth_Net() is deprecated in favor of llms_gateway_auth_dot_net().
  • Filter llms_auth_net_customer_profile_description is deprecated with no replacement.
  • File includes/class-llms-gateway-authorize.net.php is deprecated in favor of includes/class-llms-payment-gateway-authorize.net.php.