LifterLMS MailChimp

LifterLMS MailChimp Version 2.1.1

  • Added a handling function that automatically adds a user to a group if they’re already subscribed to the chosen list. This allows you to choose different interest groups for each course or membership rather than only being able to choose different lists.
  • Fixed a typo
  • Added two filters:
  • llms_mailchimp_add_contact: allows customization of merge field data sent to MailChimp
  • llms_mailchimp_double_optin: allows you to enable double optin when subscribing users to your lists

LifterLMS MailChimp Version 2.1.0

This version will work best with LifterLMS version 2.2.3 or later. Some new features will only be available if LifterLMS 2.2.3 is available

  • We’ve updated to work with LifterLMS actions for course and membership enrollment
  • When a student is added to a course by an admin via the Students tab of a Course the user will now be added to the MailChimp list & group selected for the course
  • MailChimp lists and groups can now be configured for Memberships.
  • Users who join a membership and are auto-enrolled in multiple courses will now be correctly added to MailChimp lists and groups associated with all auto-enroll courses
  • Fixed a few code standards issues
  • Updated a few functions to have more normalized programmatic responses

LifterLMS MailChimp Version 2.0.0

  • Deprecated reliance on the Plugin Update Checker class from the LifterLMS core in order to allow update and activation via the new free LifterLMS Helper plugin.
  • This version requires LifterLMS 1.5.0 at a minimum and will not function with older versions of LifterLMS.
  • Upgrading to v2.0.0 from older versions of LifterLMS MailChimp is easy, simply retrieve the update automatically from your WordPress installation. Please Note that after updating to v2.0.0 you will no longer be able to receive automatic updates without installing the free LifterLMS Helper plugin. Version 2.0.0 of LifterLMS (coming soon) will remove update functionality so we urge you to update to MailChimp v2.0.0 soon and install the updater plugin to continue receiving automatic updates.
  • Properly enqueue Javascript